新闻中心

- NEWS CENTER -

公司新闻 行业新闻
交换机介绍
点击次数:1021  【打印此页】  【关闭
交换机

交换机的工作原理

学习:学习数据帧的源MAC地址和交换机端口的对应关系

广播:交换机向除了进口之外的所有其他端口广播数据帧,查找未知的MAC地址

转发:当交换机的MAC地址表完整的形成后,交换机就会根据MAC地址表,以直播的方式来转发数据帧

更新:MAC地址表终的记录默认生存时间为300秒,300秒如果未更新,交换机就会删除此记录,从新学习

以广播的方式学习生成MAC地址表,根据MAC地址表转发数据帧。

交换机端口的双工模式

单工:一个信道,只能接受数据

半双工(half):一个信道,同一时刻只能发或接收数据

全双工(full):两个信道,可以同时收送数据

冲突域和广播域

为了避免冲突,提高网络效率,终端设备要避免在一个冲突域

冲突域:集线器的所有端口处于一个冲突域

交换机:交换机的每个端口是一个冲突域

交换机的所有端口在一个广播域里

路由器:路由的每个端口都是一个广播域

以太网的两个问题:冲突,广播

冲突:交换机

广播:生成树协议

广播风暴,分隔广播域,

三层设备(路由器,三层交换机)

隔绝冲突域的设备-交换机

隔绝广播域的设备-路由器

<switch>用户视图模式

<switch>system-view 进入系统视图

[switch]系统视图模式

命令大全

[]interface 接口号 进入接口视图

quit 返回上一视图

return 直接推到用户视图 或 ctrl+z

查询命令

Tab 补全命令

<>display version (查看系统版本)

<>undo terminal monitor 防止弹出信息干扰命令

<>save 保存当前配置

display current-configuration(查看交换机配置信息)

[]sysname xxx (修改主机名)

[]stp disable //关闭生成树 (关闭抓包时自动生存的数据包)

Interface vlan 1 //进入接口模式

Ip address 192.168.1.1 255.255.255.0(24) //配置IP地址

[g0/0/1] shutdown (关闭接口) [g0/0/0]undo shutdown (开启接口)

设置终端密码

[]user-interface console 0 //进入控制端口console 0

[]set authentication password cipher 123 //设置隐藏密码123

[]authentication-mode password //开启密码服务

更改自动退出超时:

[sw-ui-console0]idle-timeout 60

恢复出厂默认

<>reset saved-configuration // 提示是否恢复 选Y

<>reboot //提示是否保存 选N 提示是否重启 选Y

<>display mac-address //显示交换机记录的MAC地址表

<>display bridge mac-address //显示交换机本身的mac地址

[]lldp enable //开启邻居发现功能

[]display lldp neighbor(邻居) brief(摘要) //显示邻居的基本信息

[e0/0/3]undo negotiation auto //取消端口的自动协商功能

[e0/0/3]duplex half //设置端口的双工模式为半双工

[e0/0/3]speed 10(10/100) //设置端口速率为10M

[e0/0/3]display this //显示端口当前配置信息

Vlan原理

虚拟局域网

--分割广播域

--提高网络性能

--不同vlan之间是不能访问的

Vlan 的划分方式

基于端口

Vlan 10: e0/0/1 e0/0/2 e0/0/3

基于mac地址

Vlan 10: 00-0c-20-00-00-01 00-0b-30-11-22-33

Vlan数据帧封装协议

原始: 目标地址 源地址 类型 数据 校验值

Vlan: 目标地址 源地址 tag 类型 数据 校验值

Ieee802.1q协议 12位二进制数 vlan的取值范围:1-4096

Pvid

Port vlan id

交换机端口所属的vlan

交换机端口模式:access,trunk,hybrid

默认模式:hybrid

Access模式:发送数据帧的时候,不带vlan标签 PC—交换机

Trunk模式:发送数据帧的时候,带vlan标签 交换机—交换机

Hybrid模式:

--混合模式或手动模式

--发送数据帧的时候,需要手动指定带不带vlan标签

Access接入模式

PC-----------(access)交换机

数据帧进入交换机后会添加vlan tag

数据帧从发送之前要删除vlan tag

Vlan基本命令

Vlan 10 (2-4094) //创建一个vlan

[vlan10]Description sales (可选) //添加vlan的描述信息

Vlan batch 35 to 40 //创建多个连续的vlan

Vlan batch 15 20 25 30 //创建多个不连续的vlan

[]undo vlan 10 //删除一个vlan

[]undo vlan batch 20 21 25 //删除多个不连续的vlan

[]undo vlan batch 35 to 40 //删除多个连续的vlan

[]display vlan //显示vlan信息.

[]in e0/0/1

[e0/0/1]port link-type access //设置端口的模式为接入模式

[e0/0/1]port default vlan 20 //把端口加入vlan 20

[]port-group 1 //创建端口组

[sw-port-group-1]group-member e0/0/1 e0/0/3 //把不连续端口加入组

[sw-port-group-1]group-member e0/0/4 to e0/0/10 //把连续端口加入组

[sw-port-group-1]port link-type access //设置端口类型access接入模式

[sw-port-group-1]port default vlan 10 //更改端口默认vlan 为10

中继链路trunk模式

交换机(trunk)-----------------(trunk)交换机

交换机之间发送数据帧的时候需要带标签发送,除非发送数据帧的主机

所在的vlan和trunk端口所在的vlan相同,不带标签

[]interface e0/0/5

[e0/0/5]port link-type trunk

[e0/0/5]port trunk allow-pass vlan 10 20 //只允许vlan 10和20的数据通过

或 port trunk allow-pass vlan all //允许所有的vlan数据通过

Port trunk pvid vlan 10 //把trunk端口加入指定的vlan (一般可以不,打默认1)

实验排错

如果端口已经设置为trunk模式,无法直接更改为其他模式

解决方法

显示当前端口的配置信息 display
取消当前端口的相关设置 undo port trunk allow-pass vlan 2-4094
更改模式 port link-type access

Hybrid模式

[e0/0/1]port link-type hybrid //修改端口的模式为hybrid

[]port hybrid pvid vlan 10 //指定端口的vlan为10

[]port hybrid tagged vlan 10 //通过发送vlan10 的数据帧需要带标签发送

[]port hybrid untagged vlan 10 //通过发送vlan10的数据帧需要不带标签发送

PC1只能接受识别不带标签的数据帧,想要局域网内其他PC能够识别PC1的数据帧需要给其他PC所连接的端口添加一个去掉PC1vlan标签的命令 port hybrid untagged vlan n 并划分在同一vlan下。不同vlan无法互访。

三层交换机

单臂路由缺点:

--单臂会成为网络通信的瓶颈

--所有子接口全部依托于物理接口,使用不灵活

企业中实现不同vlan通信的常用设备是三层交换机

三层交换机=二层交换+三层路由

三层交换机的接口:

--交换端口 物理接口

--路由端口 虚拟的vlan接口

Vlan 10 //创建vlan

Interface g0/0/1 //进入交换机端口

Port link-type access //配置类型

Port default vlan 10 //加入vlan

Interface vlanif 10 //进vlan

Ip ad 192.168.1.1 24 //配置地址

交换网络的问题

交换机物理需要互相连接在一起:

链路备份

容易形成广播风暴

(交换机之间互相转发未知地址的数据帧)

物理没环,肯定没有广播风暴

物理有环,逻辑无环:物理上交换机连接在一起,但是总是一个或多个端口是down的状态

这样就不会形成环状拓扑,没有广播风暴

生成树协议(spanningtree protocol)stp

-逻辑上断开环路,避免广播风暴

-当其他链路有问题,阻塞端口自动激活,起到备份链路的作用

Display bridge mac-address //显示交换机mac地址

Display stp brief //显示生成树的摘要信息

Port role stp state(状态)

Ethernet0/0/1 ROOT(根端口) forwarding(转发)

Ethernet0/0/2 ALTE(阻塞端口) discarding(丢弃)

Ethernet0/0/3 DESI (指定端口) forwarding(转发)

每个非根网桥上有且只有一个根端口

每根线上有且只有一个指定端口

生成树算法:比小

三个选举步骤:

第一步:选择根网桥(每个广播域选一个)

第二步:选择根端口(每个非根网桥上选一个)

第三步:选择指定端口(每根线上选一个)

第一步:选择根网桥(每个广播域选一个)

网桥ID=网桥优先级+网桥mac地址

网桥优先级:

范围0-65535

默认值32768

步长4096

第二步:选择根端口(每个非根网桥上选一个)

此端口到达根网桥的路径成本之和最低
路径成本: 1000M 20000

100M 200000

跟此端口直连的交换机的网桥ID最小
端口标识最小
端口标识=端口优先级+端口号

端口优先级: 范围0-240 默认值128 步长16

端口号:e0/0/1 e0/0/10

第三步:选择指定端口(每根线上选一个)

根网桥上的所有端口都是指定端口

此端口所在的交换机到达根网桥的路径成本最低
此端口所在的交换机网桥ID最小
端口标识最小

BPDU桥协议数据单元

交换机发送BPDU使用的是组播的方式

配置BPDU:交换机启动时把自己的配置情况告诉给别的交换机

拓扑变更(tcn)bpdu:交换机网络拓扑发生变化,把变化告诉别的交换机

stp端口状态

禁用 disabled 强制关闭

阻塞 blocking 只能接收bpdu

侦听 listening 可以接收和发送bpdu

学习 learning 学习mac地址表

转发 forwarding 转发数据帧

生成树计时器:

Hello时间 2秒

转发延迟 15秒

最大老化时间 20秒

Stp收敛时间:30-50秒

Stp配置命令

Stp enable | disable //开启或关闭生成树协议

Stp mode mstp //多生成树(默认)

Stp //普通生成树

Rstp //快速生成树

Stp priority 4096【0-61440】 //设置优先级 每4096为一个单位

Stp root secondary

Stp priority 0 = stp root primary //设置优先级为0

【e0/0/0】stp cost 20000 //设置开销值(路径长度)

【huawei】stp disable //禁用生成树功能

【huawei-e0/0/0】stp disable //不让此端口参与生成树选举

多生成树mstp

为网络生成多条路,每一条路允许一些vlan来通过

格式:创建路(指定特定的根网桥)==》这条路允许谁通过

设置多生成树:

先禁用pc机和交换机相连的生成树功能。
创建vlan
把端口加入相应的vlan,设置端口模式trunk
配置多生成树(所有关联的交换机都要创建以下配置)
Stp region-configuration //进入生成树域的配置

Region-name abc //设置生成树域的名字

Instance 1 vlan 10 20 … //创建第一条路,并指定允许哪些vlan使用

Instance 2 vlan 5 15 … //创建第二条路,并指定允许哪些vlan使用

Active region-configuration //激活生成树域

指定每条路的根网桥

【sw1】Stp instance 1 priority 0 //指定sw1为第一条路的根网桥

【sw2】stp instance 2 priority 0 //指定sw2为第二条路的根网桥

在交换机环形拓扑中,Stp的存在能确保无环拓扑,避免网络风暴,达到备份链路的作用。

手动创造多路多生成树可以达到流量路径控制,负载均衡的作用。
上一篇:伺服液压缸的结构与性能
下一篇:网络交换机怎么选?
Copy right ©2020 版权所有:苏州申一智能科技有限公司 备案号:苏ICP备2020067563号-1 航空插头 非标减速机 三坐标测量机 微电机
Top